GoldenGate Extract Abending on NFS Trail: OGG-02897 / OGG-01668 Input/Output...
While working on a client’s GoldenGate 26ai environment, I ran into a NFS-related replication issue that could have been serious, had it happened in production. Here is what happened and how the issue...
View ArticleMongoDB Log Analysis : A Comprehensive Guide
Contrary to other DBMS, MongoDB self-managed deployments generate logs in a JSON format, which can be quite intimidating at first. But instead of hoping to never have to look at the logs, you can use...
View ArticleOracle 21c: Attention Log – Useful or Superflous?
Attention.log is a feature, which was introduced in Oracle Database 21c, designed to capture high-level summaries of significant database events and activities. It differs from the alert.log in...
View ArticleHow I killed my M-Files instance…and brought it back to life!
I work with M-Files since 1 year now, and to be honest the solution is pretty robust.I had really few issues at “Server level”, but sooner and later while playing sorcerer’s apprentice you finish by...
View ArticleHow to delete a resource with the error: failed calling webhook
The original mistake In preparation of the GitLab essentials workshop, I’m using helm to deploy it. After a few tests, I wanted to clean up my cluster, and accidentally deleted the namespace before...
View ArticleODA and KVM: Debugging of DBsystem creation failure
Debugging errors when working with ODA is not always the easiest thing do… It may become a bit tricky and not a straightforward process. In this blog I wanted to show you and example we faced with the...
View ArticleHow to view and change SQL Server Agent properties with T-SQL queries
Few days ago, after a reboot, we had this warning on the Agent Error Logs on many servers: Warning [396] An idle CPU condition has not been defined – OnIdle job schedules will have no effect “The CPU...
View ArticleUpgrade to Oracle 19c – performance issue
In this blog I want to introduce you to a workaround for a performance issue which randomly appeared during the upgrades of several Oracle 12c databases to 19c I performed for a financial services...
View ArticleTroubleshooting performance on Autonomous Database
By Franck Pachot . On my Oracle Cloud Free Tier Autonomous Transaction Processing service, a database that can be used for free with no time limit, I have seen this strange activity. As I’m running...
View ArticleSQL Server Tips: Path of the default trace file is null
In addition of my precedent blog about this subject “SQL Server Tips: Default trace enabled but no file is active…”, I add a new case where the default path of the trace file was empty. The first step...
View ArticleSQL Server Tips: Orphan database user but not so orphan…
Beginning of this year, it is good to clean up orphan users in SQL Server databases. Even if this practice must be done regularly throughout the year of course. During my cleaning day, a new case...
View ArticleWhat to do in case all active Documentum jobs are no more running ?
The application support informed me that their jobs are not running anymore. When I started the analysis, I found that all activated jobs did not start for a few weeks. First of all, I decided to work...
View ArticleOooooops or how to undelete a file on an ext4 filesystem
It happens within the blink of an eye. A delete command was executed and half a second after you hit the enter button you knew it. That was a mistake. This is the scenario which leads to this blog...
View ArticleSQL Server Tips: How many different datetime are in my column and what the...
Few months ago, a customer asks me for finding in a column, how many rows exist with the same date & time and the delta between them. The column default value is based on the function...
View ArticleNew features and known issues with RMAN tool on Oracle database 12.1.0.2
Oracle Database 12c has new enhancements and additions in Recovery Manager (RMAN). The RMAN tool continues to enhance and extend the reliability, efficiency, and availability of Oracle Database Backup...
View ArticleODA and KVM: Debugging of DBsystem creation failure
Debugging errors when working with ODA is not always the easiest thing do… It may become a bit tricky and not a straightforward process. In this blog I wanted to show you and example we faced with the...
View ArticleHow to view and change SQL Server Agent properties with T-SQL queries
Few days ago, after a reboot, we had this warning on the Agent Error Logs on many servers: Warning [396] An idle CPU condition has not been defined – OnIdle job schedules will have no effect “The CPU...
View ArticleUpgrade to Oracle 19c – performance issue
In this blog I want to introduce you to a workaround for a performance issue which randomly appeared during the upgrades of several Oracle 12c databases to 19c I performed for a financial services...
View ArticleTroubleshooting performance on Autonomous Database
By Franck Pachot . On my Oracle Cloud Free Tier Autonomous Transaction Processing service, a database that can be used for free with no time limit, I have seen this strange activity. As I’m running...
View ArticleSQL Server Tips: Path of the default trace file is null
In addition of my precedent blog about this subject “SQL Server Tips: Default trace enabled but no file is active…”, I add a new case where the default path of the trace file was empty. The first step...
View Article